summaryrefslogtreecommitdiff
path: root/contrib/python/podman/setup.py
diff options
context:
space:
mode:
authorOpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>2019-01-10 11:11:46 -0800
committerGitHub <noreply@github.com>2019-01-10 11:11:46 -0800
commit6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8 (patch)
treecf6e4191124ea1c44b9cadb504c0b2f5e6269a50 /contrib/python/podman/setup.py
parente4525cf844535014923a2253e8531d92d9e556e5 (diff)
parent45fb935fe44a383ae14f16ab533281687d642c5e (diff)
downloadpodman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.tar.gz
podman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.tar.bz2
podman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.zip
Merge pull request #2119 from jwhonce/wip/python_podman
Move python code from contrib to it's own repo python-podman
Diffstat (limited to 'contrib/python/podman/setup.py')
-rwxr-xr-xcontrib/python/podman/setup.py38
1 files changed, 0 insertions, 38 deletions
diff --git a/contrib/python/podman/setup.py b/contrib/python/podman/setup.py
deleted file mode 100755
index 9d54bb3ac..000000000
--- a/contrib/python/podman/setup.py
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/env python
-
-import os
-
-from setuptools import find_packages, setup
-
-
-root = os.path.abspath(os.path.dirname(__file__))
-
-with open(os.path.join(root, 'README.md')) as me:
- readme = me.read()
-
-with open(os.path.join(root, 'requirements.txt')) as r:
- requirements = r.read().splitlines()
-
-
-setup(
- name='podman',
- version=os.environ.get('PODMAN_VERSION', '0.0.0'),
- description='A library for communicating with a Podman server',
- author='Jhon Honce',
- author_email='jhonce@redhat.com',
- license='Apache Software License',
- long_description=readme,
- include_package_data=True,
- install_requires=requirements,
- packages=find_packages(exclude=['test']),
- python_requires='>=3',
- zip_safe=True,
- url='http://github.com/containers/libpod',
- keywords='varlink libpod podman',
- classifiers=[
- 'Development Status :: 3 - Alpha',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Apache Software License',
- 'Programming Language :: Python :: 3.4',
- 'Topic :: Software Development',
- ])