summaryrefslogtreecommitdiff
path: root/contrib/python/podman/setup.py
diff options
context:
space:
mode:
authorJhon Honce <jhonce@redhat.com>2018-07-16 17:29:50 -0700
committerAtomic Bot <atomic-devel@projectatomic.io>2018-07-23 18:53:44 +0000
commit9a18681ba62d1a297809c243607a7b3763131c36 (patch)
tree8333f8727fd7d32f81cb1f54754ccd138a7e1063 /contrib/python/podman/setup.py
parent8569ed03056ce39e0dc163747089ed4b60b1b9b1 (diff)
downloadpodman-9a18681ba62d1a297809c243607a7b3763131c36.tar.gz
podman-9a18681ba62d1a297809c243607a7b3763131c36.tar.bz2
podman-9a18681ba62d1a297809c243607a7b3763131c36.zip
[WIP] Refactor and simplify python builds
* pypodman namespaced in site-packages * version numbers pulled from requirements.txt * add python-podman spec file to install eggs Signed-off-by: Jhon Honce <jhonce@redhat.com> Closes: #1106 Approved by: rhatdan
Diffstat (limited to 'contrib/python/podman/setup.py')
-rw-r--r--contrib/python/podman/setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/contrib/python/podman/setup.py b/contrib/python/podman/setup.py
index c9db30199..a342c05fd 100644
--- a/contrib/python/podman/setup.py
+++ b/contrib/python/podman/setup.py
@@ -15,24 +15,22 @@ with open(os.path.join(root, 'requirements.txt')) as r:
setup(
name='podman',
version=os.environ.get('PODMAN_VERSION', '0.0.0'),
- description='A client for communicating with a Podman server',
- long_description=readme,
+ description='A library for communicating with a Podman server',
author='Jhon Honce',
author_email='jhonce@redhat.com',
- url='http://github.com/projectatomic/libpod',
license='Apache Software License',
- python_requires='>=3',
+ long_description=readme,
include_package_data=True,
install_requires=requirements,
packages=find_packages(exclude=['test']),
+ python_requires='>=3',
zip_safe=True,
+ url='http://github.com/projectatomic/libpod',
keywords='varlink libpod podman',
classifiers=[
'Development Status :: 3 - Alpha',
'Intended Audience :: Developers',
- 'Topic :: Software Development',
'License :: OSI Approved :: Apache Software License',
- 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.4',
+ 'Topic :: Software Development',
])
-# Not supported
-# long_description_content_type='text/markdown',