summaryrefslogtreecommitdiff
path: root/contrib/python/pypodman/setup.py
diff options
context:
space:
mode:
authorMatthew Heon <matthew.heon@gmail.com>2018-07-13 16:34:51 -0400
committerGitHub <noreply@github.com>2018-07-13 16:34:51 -0400
commita689639a6502bab3f49b853bc2983c1b44363b2f (patch)
tree75ba256d70545d79aa61d7c57c20df886be1555f /contrib/python/pypodman/setup.py
parent14a6d51a8432fc0c3324fec02e8729d3032f2af2 (diff)
parent74ccd9ce5f29a1df4ffe70b4d8bd00c29d5d9d15 (diff)
downloadpodman-a689639a6502bab3f49b853bc2983c1b44363b2f.tar.gz
podman-a689639a6502bab3f49b853bc2983c1b44363b2f.tar.bz2
podman-a689639a6502bab3f49b853bc2983c1b44363b2f.zip
Merge pull request #1081 from jwhonce/wip/client
remote python client for podman
Diffstat (limited to 'contrib/python/pypodman/setup.py')
-rw-r--r--contrib/python/pypodman/setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/contrib/python/pypodman/setup.py b/contrib/python/pypodman/setup.py
new file mode 100644
index 000000000..0483eb71c
--- /dev/null
+++ b/contrib/python/pypodman/setup.py
@@ -0,0 +1,44 @@
+import os
+
+from setuptools import find_packages, setup
+
+root = os.path.abspath(os.path.dirname(__file__))
+
+with open(os.path.join(root, 'README.md')) as me:
+ readme = me.read()
+
+with open(os.path.join(root, 'requirements.txt')) as r:
+ requirements = r.read().splitlines()
+
+print(find_packages(where='pypodman', exclude=['test']))
+
+setup(
+ name='pypodman',
+ version=os.environ.get('PODMAN_VERSION', '0.0.0'),
+ description='A client for communicating with a Podman server',
+ author_email='jhonce@redhat.com',
+ author='Jhon Honce',
+ license='Apache Software License',
+ long_description=readme,
+ entry_points={'console_scripts': [
+ 'pypodman = lib.pypodman:main',
+ ]},
+ include_package_data=True,
+ install_requires=requirements,
+ keywords='varlink libpod podman pypodman',
+ packages=find_packages(exclude=['test']),
+ python_requires='>=3',
+ zip_safe=True,
+ url='http://github.com/projectatomic/libpod',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: Microsoft :: Windows',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3.6',
+ 'Topic :: System :: Systems Administration',
+ 'Topic :: Utilities',
+ ])