summaryrefslogtreecommitdiff
path: root/contrib/python/pypodman/setup.py
diff options
context:
space:
mode:
authorOpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>2019-01-10 11:11:46 -0800
committerGitHub <noreply@github.com>2019-01-10 11:11:46 -0800
commit6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8 (patch)
treecf6e4191124ea1c44b9cadb504c0b2f5e6269a50 /contrib/python/pypodman/setup.py
parente4525cf844535014923a2253e8531d92d9e556e5 (diff)
parent45fb935fe44a383ae14f16ab533281687d642c5e (diff)
downloadpodman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.tar.gz
podman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.tar.bz2
podman-6524041fb0ebfc35dafe3bb7bebbd4dfa27ba5e8.zip
Merge pull request #2119 from jwhonce/wip/python_podman
Move python code from contrib to it's own repo python-podman
Diffstat (limited to 'contrib/python/pypodman/setup.py')
-rwxr-xr-xcontrib/python/pypodman/setup.py45
1 files changed, 0 insertions, 45 deletions
diff --git a/contrib/python/pypodman/setup.py b/contrib/python/pypodman/setup.py
deleted file mode 100755
index f07e89201..000000000
--- a/contrib/python/pypodman/setup.py
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/usr/bin/env python
-
-import os
-
-from setuptools import find_packages, setup
-
-root = os.path.abspath(os.path.dirname(__file__))
-
-with open(os.path.join(root, 'README.md')) as me:
- readme = me.read()
-
-with open(os.path.join(root, 'requirements.txt')) as r:
- requirements = r.read().splitlines()
-
-
-setup(
- name='pypodman',
- version=os.environ.get('PODMAN_VERSION', '0.0.0'),
- description='A client for communicating with a Podman server',
- author_email='jhonce@redhat.com',
- author='Jhon Honce',
- license='Apache Software License',
- long_description=readme,
- entry_points={'console_scripts': [
- 'pypodman = pypodman.main:main',
- ]},
- include_package_data=True,
- install_requires=requirements,
- packages=find_packages(exclude=['test']),
- python_requires='>=3',
- zip_safe=True,
- url='http://github.com/containers/libpod',
- keywords='varlink libpod podman pypodman',
- classifiers=[
- 'Development Status :: 3 - Alpha',
- 'Intended Audience :: Developers',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: MacOS :: MacOS X',
- 'Operating System :: Microsoft :: Windows',
- 'Operating System :: POSIX',
- 'Programming Language :: Python :: 3.4',
- 'Topic :: System :: Systems Administration',
- 'Topic :: Utilities',
- ])