summaryrefslogtreecommitdiff
path: root/contrib/python/pypodman/setup.py
diff options
context:
space:
mode:
authorJhon Honce <jhonce@redhat.com>2018-07-16 17:29:50 -0700
committerAtomic Bot <atomic-devel@projectatomic.io>2018-07-23 18:53:44 +0000
commit9a18681ba62d1a297809c243607a7b3763131c36 (patch)
tree8333f8727fd7d32f81cb1f54754ccd138a7e1063 /contrib/python/pypodman/setup.py
parent8569ed03056ce39e0dc163747089ed4b60b1b9b1 (diff)
downloadpodman-9a18681ba62d1a297809c243607a7b3763131c36.tar.gz
podman-9a18681ba62d1a297809c243607a7b3763131c36.tar.bz2
podman-9a18681ba62d1a297809c243607a7b3763131c36.zip
[WIP] Refactor and simplify python builds
* pypodman namespaced in site-packages * version numbers pulled from requirements.txt * add python-podman spec file to install eggs Signed-off-by: Jhon Honce <jhonce@redhat.com> Closes: #1106 Approved by: rhatdan
Diffstat (limited to 'contrib/python/pypodman/setup.py')
-rw-r--r--contrib/python/pypodman/setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/contrib/python/pypodman/setup.py b/contrib/python/pypodman/setup.py
index 04f8fb5f5..0509bf942 100644
--- a/contrib/python/pypodman/setup.py
+++ b/contrib/python/pypodman/setup.py
@@ -10,6 +10,7 @@ with open(os.path.join(root, 'README.md')) as me:
with open(os.path.join(root, 'requirements.txt')) as r:
requirements = r.read().splitlines()
+
setup(
name='pypodman',
version=os.environ.get('PODMAN_VERSION', '0.0.0'),
@@ -19,15 +20,15 @@ setup(
license='Apache Software License',
long_description=readme,
entry_points={'console_scripts': [
- 'pypodman = lib.pypodman:main',
+ 'pypodman = pypodman.main:main',
]},
include_package_data=True,
install_requires=requirements,
- keywords='varlink libpod podman pypodman',
packages=find_packages(exclude=['test']),
python_requires='>=3',
zip_safe=True,
url='http://github.com/projectatomic/libpod',
+ keywords='varlink libpod podman pypodman',
classifiers=[
'Development Status :: 3 - Alpha',
'Intended Audience :: Developers',
@@ -36,7 +37,7 @@ setup(
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX',
- 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.4',
'Topic :: System :: Systems Administration',
'Topic :: Utilities',
])