summaryrefslogtreecommitdiff
path: root/contrib/python/pypodman/setup.py
diff options
context:
space:
mode:
authorJhon Honce <jhonce@redhat.com>2018-07-12 19:26:14 -0700
committerJhon Honce <jhonce@redhat.com>2018-07-13 12:50:12 -0700
commit74ccd9ce5f29a1df4ffe70b4d8bd00c29d5d9d15 (patch)
tree75ba256d70545d79aa61d7c57c20df886be1555f /contrib/python/pypodman/setup.py
parent44b523c946c88e540b50d7ba59f441b5f8e0bad0 (diff)
downloadpodman-74ccd9ce5f29a1df4ffe70b4d8bd00c29d5d9d15.tar.gz
podman-74ccd9ce5f29a1df4ffe70b4d8bd00c29d5d9d15.tar.bz2
podman-74ccd9ce5f29a1df4ffe70b4d8bd00c29d5d9d15.zip
Update python directories to better support setup.py
Signed-off-by: Jhon Honce <jhonce@redhat.com>
Diffstat (limited to 'contrib/python/pypodman/setup.py')
-rw-r--r--contrib/python/pypodman/setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/contrib/python/pypodman/setup.py b/contrib/python/pypodman/setup.py
new file mode 100644
index 000000000..0483eb71c
--- /dev/null
+++ b/contrib/python/pypodman/setup.py
@@ -0,0 +1,44 @@
+import os
+
+from setuptools import find_packages, setup
+
+root = os.path.abspath(os.path.dirname(__file__))
+
+with open(os.path.join(root, 'README.md')) as me:
+ readme = me.read()
+
+with open(os.path.join(root, 'requirements.txt')) as r:
+ requirements = r.read().splitlines()
+
+print(find_packages(where='pypodman', exclude=['test']))
+
+setup(
+ name='pypodman',
+ version=os.environ.get('PODMAN_VERSION', '0.0.0'),
+ description='A client for communicating with a Podman server',
+ author_email='jhonce@redhat.com',
+ author='Jhon Honce',
+ license='Apache Software License',
+ long_description=readme,
+ entry_points={'console_scripts': [
+ 'pypodman = lib.pypodman:main',
+ ]},
+ include_package_data=True,
+ install_requires=requirements,
+ keywords='varlink libpod podman pypodman',
+ packages=find_packages(exclude=['test']),
+ python_requires='>=3',
+ zip_safe=True,
+ url='http://github.com/projectatomic/libpod',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: Microsoft :: Windows',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3.6',
+ 'Topic :: System :: Systems Administration',
+ 'Topic :: Utilities',
+ ])