summaryrefslogtreecommitdiff
path: root/nix/default-arm64.nix
diff options
context:
space:
mode:
authorOpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>2021-07-14 15:45:01 -0400
committerGitHub <noreply@github.com>2021-07-14 15:45:01 -0400
commitbf5fee92139b0ae4e154e80345849e349043b7cb (patch)
treef7e12bd11cc4e37308a46a2624c6bcf6c74675ec /nix/default-arm64.nix
parentce4c23c4af3adb6b2d41d337720bb78be5db0f71 (diff)
parent92c9def930342adfecbcb55d93d5097ea0e46ec7 (diff)
downloadpodman-bf5fee92139b0ae4e154e80345849e349043b7cb.tar.gz
podman-bf5fee92139b0ae4e154e80345849e349043b7cb.tar.bz2
podman-bf5fee92139b0ae4e154e80345849e349043b7cb.zip
Merge pull request #10931 from alvistack/master-linux-amd64
Update nix pin with `make nixpkgs`
Diffstat (limited to 'nix/default-arm64.nix')
-rw-r--r--nix/default-arm64.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nix/default-arm64.nix b/nix/default-arm64.nix
index d29f75520..8868788ae 100644
--- a/nix/default-arm64.nix
+++ b/nix/default-arm64.nix
@@ -30,8 +30,10 @@ let
"--enable-confdir=/etc"
"--enable-usbdropdir=/var/lib/pcsc/drivers"
"--disable-libsystemd"
+ "--disable-libudev"
+ "--disable-libusb"
];
- buildInputs = [ pkgs.python3 pkgs.udev pkgs.dbus pkgs.systemd ];
+ buildInputs = [ pkgs.python3 pkgs.dbus ];
});
systemd = (static pkg.systemd).overrideAttrs (x: {
outputs = [ "out" "dev" ];
@@ -69,6 +71,7 @@ let
export LDFLAGS='-s -w -static-libgcc -static'
export EXTRA_LDFLAGS='-s -w -linkmode external -extldflags "-static -lm"'
export BUILDTAGS='static netgo osusergo exclude_graphdriver_btrfs exclude_graphdriver_devicemapper seccomp apparmor selinux'
+ export CGO_ENABLED=1
'';
buildPhase = ''
patchShebangs .