summaryrefslogtreecommitdiff
path: root/nix/default-arm64.nix
diff options
context:
space:
mode:
authorWong Hoi Sing Edison <hswong3i@pantarei-design.com>2021-06-17 14:47:19 +0800
committerWong Hoi Sing Edison <hswong3i@pantarei-design.com>2021-07-14 21:20:37 +0800
commit92c9def930342adfecbcb55d93d5097ea0e46ec7 (patch)
treee8064a5ca57d48a285e9b3f06f7691851a91541f /nix/default-arm64.nix
parent9d98f56a64852d3bf9d3b27ad6e1ac3e3ebb6622 (diff)
downloadpodman-92c9def930342adfecbcb55d93d5097ea0e46ec7.tar.gz
podman-92c9def930342adfecbcb55d93d5097ea0e46ec7.tar.bz2
podman-92c9def930342adfecbcb55d93d5097ea0e46ec7.zip
Update nix pin with `make nixpkgs`
Signed-off-by: Wong Hoi Sing Edison <hswong3i@pantarei-design.com>
Diffstat (limited to 'nix/default-arm64.nix')
-rw-r--r--nix/default-arm64.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nix/default-arm64.nix b/nix/default-arm64.nix
index d29f75520..8868788ae 100644
--- a/nix/default-arm64.nix
+++ b/nix/default-arm64.nix
@@ -30,8 +30,10 @@ let
"--enable-confdir=/etc"
"--enable-usbdropdir=/var/lib/pcsc/drivers"
"--disable-libsystemd"
+ "--disable-libudev"
+ "--disable-libusb"
];
- buildInputs = [ pkgs.python3 pkgs.udev pkgs.dbus pkgs.systemd ];
+ buildInputs = [ pkgs.python3 pkgs.dbus ];
});
systemd = (static pkg.systemd).overrideAttrs (x: {
outputs = [ "out" "dev" ];
@@ -69,6 +71,7 @@ let
export LDFLAGS='-s -w -static-libgcc -static'
export EXTRA_LDFLAGS='-s -w -linkmode external -extldflags "-static -lm"'
export BUILDTAGS='static netgo osusergo exclude_graphdriver_btrfs exclude_graphdriver_devicemapper seccomp apparmor selinux'
+ export CGO_ENABLED=1
'';
buildPhase = ''
patchShebangs .