summaryrefslogtreecommitdiff
path: root/nix/default-arm64.nix
diff options
context:
space:
mode:
authorWong Hoi Sing Edison <hswong3i@pantarei-design.com>2021-06-03 11:16:17 +0800
committerWong Hoi Sing Edison <hswong3i@pantarei-design.com>2021-06-10 10:36:38 +0800
commite7e09bf2f0abdbfa6a1cc7f75bfbd795f80624d6 (patch)
tree93eb7efa2553c8b99a3042ab5a4272f327fca331 /nix/default-arm64.nix
parentea39735845655aaf77de577a35557a0fb003514f (diff)
downloadpodman-e7e09bf2f0abdbfa6a1cc7f75bfbd795f80624d6.tar.gz
podman-e7e09bf2f0abdbfa6a1cc7f75bfbd795f80624d6.tar.bz2
podman-e7e09bf2f0abdbfa6a1cc7f75bfbd795f80624d6.zip
Update nix pin with `make nixpkgs`
- Bugfix `make nixpkgs` which pin with branch `nixos-21.05` - Code lint with `nixpkgs-fmt` - Code sync between x86\_64 and aarch64 Signed-off-by: Wong Hoi Sing Edison <hswong3i@pantarei-design.com>
Diffstat (limited to 'nix/default-arm64.nix')
-rw-r--r--nix/default-arm64.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/nix/default-arm64.nix b/nix/default-arm64.nix
index 3e374c1bd..d29f75520 100644
--- a/nix/default-arm64.nix
+++ b/nix/default-arm64.nix
@@ -25,6 +25,21 @@ let
-i "$dev"/include/glib-2.0/gobject/gobjectnotifyqueue.c
'';
});
+ pcsclite = (static pkg.pcsclite).overrideAttrs (x: {
+ configureFlags = [
+ "--enable-confdir=/etc"
+ "--enable-usbdropdir=/var/lib/pcsc/drivers"
+ "--disable-libsystemd"
+ ];
+ buildInputs = [ pkgs.python3 pkgs.udev pkgs.dbus pkgs.systemd ];
+ });
+ systemd = (static pkg.systemd).overrideAttrs (x: {
+ outputs = [ "out" "dev" ];
+ mesonFlags = x.mesonFlags ++ [
+ "-Dglib=false"
+ "-Dstatic-libsystemd=true"
+ ];
+ });
};
};
});
@@ -47,8 +62,8 @@ let
doCheck = false;
enableParallelBuilding = true;
outputs = [ "out" ];
- nativeBuildInputs = [ bash gitMinimal go-md2man installShellFiles makeWrapper pkg-config which ];
- buildInputs = [ glibc glibc.static gpgme libassuan libgpgerror libseccomp libapparmor libselinux ];
+ nativeBuildInputs = [ bash gitMinimal go-md2man pkg-config which ];
+ buildInputs = [ glibc glibc.static glib gpgme libassuan libgpgerror libseccomp libapparmor libselinux ];
prePatch = ''
export CFLAGS='-static -pthread'
export LDFLAGS='-s -w -static-libgcc -static'