summaryrefslogtreecommitdiff
path: root/nix/default.nix
diff options
context:
space:
mode:
authorWong Hoi Sing Edison <hswong3i@pantarei-design.com>2020-12-01 14:53:35 +0800
committerWong Hoi Sing Edison <hswong3i@pantarei-design.com>2020-12-20 18:41:22 +0800
commit0599b2185768a5656e7f782fd040ec6b18cdb825 (patch)
treeb94a6d55e7560da6e1edb0ca46bb5568904dbccd /nix/default.nix
parent5c6b5ef34905f40562b518799c35be8d06694e65 (diff)
downloadpodman-0599b2185768a5656e7f782fd040ec6b18cdb825.tar.gz
podman-0599b2185768a5656e7f782fd040ec6b18cdb825.tar.bz2
podman-0599b2185768a5656e7f782fd040ec6b18cdb825.zip
Update nix pin with `make nixpkgs`
This PR introduce 3 changes: - Upgrade Nix stable channel from 20.03 to 20.09. NixOS 20.09 released at 2020-10-27, see <https://nixos.org/manual/nixos/stable/release-notes.html#sec-release-20.09> for more information. - Replace `git` with `gitMinimal`. All 6 projects (i.e. crun/conmon/skopeo/buildah/podman/cri-o) are having `git` as dependency for failsafe during bootstrap. BTW <https://github.com/NixOS/nixpkgs/pull/104896> replace `asciidoc` with `asciidoctor` so trigger the dependency chain to `glib` and so failed (see below). Switching to `gitMinimal` skip this dependency chain to `glib`, which also speed up overall build process. - Adding `-pthread` for `glib` `conmon` couldn't skip the error by replacing `git` with `gitMinimal` since it do depend on `glib`. Since `glib` trigger error message "undefined reference to 'pthread\_create'", therefore adding `pthread` to `CFLAGS` could solve the problem. Also see: - <https://github.com/containers/crun/pull/550> - <https://github.com/containers/conmon/pull/218> - <https://github.com/containers/skopeo/pull/1120> - <https://github.com/containers/buildah/pull/2831> - <https://github.com/containers/podman/pull/8526> - <https://github.com/cri-o/cri-o/pull/4395> Signed-off-by: Wong Hoi Sing Edison <hswong3i@pantarei-design.com>
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/default.nix b/nix/default.nix
index a1a8c5287..13b4585ea 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -38,10 +38,10 @@ let
doCheck = false;
enableParallelBuilding = true;
outputs = [ "out" ];
- nativeBuildInputs = [ bash git go-md2man installShellFiles makeWrapper pkg-config which ];
+ nativeBuildInputs = [ bash gitMinimal go-md2man installShellFiles makeWrapper pkg-config which ];
buildInputs = [ glibc glibc.static gpgme libassuan libgpgerror libseccomp libapparmor libselinux ];
prePatch = ''
- export CFLAGS='-static'
+ export CFLAGS='-static -pthread'
export LDFLAGS='-s -w -static-libgcc -static'
export EXTRA_LDFLAGS='-s -w -linkmode external -extldflags "-static -lm"'
export BUILDTAGS='static netgo osusergo exclude_graphdriver_btrfs exclude_graphdriver_devicemapper seccomp apparmor selinux'