summaryrefslogtreecommitdiff
path: root/nix/default.nix
diff options
context:
space:
mode:
authorOpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>2021-07-14 15:45:01 -0400
committerGitHub <noreply@github.com>2021-07-14 15:45:01 -0400
commitbf5fee92139b0ae4e154e80345849e349043b7cb (patch)
treef7e12bd11cc4e37308a46a2624c6bcf6c74675ec /nix/default.nix
parentce4c23c4af3adb6b2d41d337720bb78be5db0f71 (diff)
parent92c9def930342adfecbcb55d93d5097ea0e46ec7 (diff)
downloadpodman-bf5fee92139b0ae4e154e80345849e349043b7cb.tar.gz
podman-bf5fee92139b0ae4e154e80345849e349043b7cb.tar.bz2
podman-bf5fee92139b0ae4e154e80345849e349043b7cb.zip
Merge pull request #10931 from alvistack/master-linux-amd64
Update nix pin with `make nixpkgs`
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/nix/default.nix b/nix/default.nix
index f6194e3d9..4d15532c2 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -27,9 +27,11 @@ let
configureFlags = [
"--enable-confdir=/etc"
"--enable-usbdropdir=/var/lib/pcsc/drivers"
- "--with-systemdsystemunitdir=${placeholder "bin"}/lib/systemd/system"
+ "--disable-libsystemd"
+ "--disable-libudev"
+ "--disable-libusb"
];
- buildInputs = [ pkgs.python3 pkgs.udev pkgs.dbus pkgs.systemd ];
+ buildInputs = [ pkgs.python3 pkgs.dbus ];
});
systemd = (static pkg.systemd).overrideAttrs (x: {
outputs = [ "out" "dev" ];
@@ -67,6 +69,7 @@ let
export LDFLAGS='-s -w -static-libgcc -static'
export EXTRA_LDFLAGS='-s -w -linkmode external -extldflags "-static -lm"'
export BUILDTAGS='static netgo osusergo exclude_graphdriver_btrfs exclude_graphdriver_devicemapper seccomp apparmor selinux'
+ export CGO_ENABLED=1
'';
buildPhase = ''
patchShebangs .