summaryrefslogtreecommitdiff
path: root/nix/default.nix
diff options
context:
space:
mode:
authorOpenShift Merge Robot <openshift-merge-robot@users.noreply.github.com>2020-12-21 12:53:36 +0000
committerGitHub <noreply@github.com>2020-12-21 12:53:36 +0000
commitd6925182cdaf94225908a386d02eae8fd3e01123 (patch)
treeb94a6d55e7560da6e1edb0ca46bb5568904dbccd /nix/default.nix
parent5c6b5ef34905f40562b518799c35be8d06694e65 (diff)
parent0599b2185768a5656e7f782fd040ec6b18cdb825 (diff)
downloadpodman-d6925182cdaf94225908a386d02eae8fd3e01123.tar.gz
podman-d6925182cdaf94225908a386d02eae8fd3e01123.tar.bz2
podman-d6925182cdaf94225908a386d02eae8fd3e01123.zip
Merge pull request #8526 from alvistack/master-linux-amd64
Update nix pin with `make nixpkgs`
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/default.nix b/nix/default.nix
index a1a8c5287..13b4585ea 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -38,10 +38,10 @@ let
doCheck = false;
enableParallelBuilding = true;
outputs = [ "out" ];
- nativeBuildInputs = [ bash git go-md2man installShellFiles makeWrapper pkg-config which ];
+ nativeBuildInputs = [ bash gitMinimal go-md2man installShellFiles makeWrapper pkg-config which ];
buildInputs = [ glibc glibc.static gpgme libassuan libgpgerror libseccomp libapparmor libselinux ];
prePatch = ''
- export CFLAGS='-static'
+ export CFLAGS='-static -pthread'
export LDFLAGS='-s -w -static-libgcc -static'
export EXTRA_LDFLAGS='-s -w -linkmode external -extldflags "-static -lm"'
export BUILDTAGS='static netgo osusergo exclude_graphdriver_btrfs exclude_graphdriver_devicemapper seccomp apparmor selinux'