summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJhon Honce <jhonce@redhat.com>2022-02-28 16:26:43 -0700
committerJhon Honce <jhonce@redhat.com>2022-03-01 09:06:52 -0700
commit7729afe9793632673c978b347ccbd999b5152042 (patch)
tree964f4b72234186163b4a7677c080d84e82790a48 /pyproject.toml
parentc39dffe83db9fa3cfa6897b971956821f1bbcce2 (diff)
downloadpodman-7729afe9793632673c978b347ccbd999b5152042.tar.gz
podman-7729afe9793632673c978b347ccbd999b5152042.tar.bz2
podman-7729afe9793632673c978b347ccbd999b5152042.zip
Refactor docker-py compatibility tests
* Add which python client is being used to run tests, see "python client" below. * Remove redundate code from test classes * Update/Add comments to modules and classes ======================================================= test session starts ======================================================== platform linux -- Python 3.10.0, pytest-6.2.4, py-1.10.0, pluggy-0.13.1 python client -- DockerClient rootdir: /home/jhonce/Projects/go/src/github.com/containers/podman plugins: requests-mock-1.8.0 collected 33 items test/python/docker/compat/test_containers.py ...s.............. [ 54%] test/python/docker/compat/test_images.py ............ [ 90%] test/python/docker/compat/test_system.py ... [100%] Note: Follow-up PRs will verify the test results and expand the tests. Signed-off-by: Jhon Honce <jhonce@redhat.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 000000000..5a31279c6
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,15 @@
+[tool.black]
+line-length = 100
+target-version = ['py36']
+include = '\.pyi?$'
+exclude = '''
+/(
+ \.git
+ | \.tox
+ | \.venv
+ | build
+ | dist
+ | docs
+ | hack
+)/
+'''